GHSA-c2rv-hwqm-wjpg

Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes

At a glance

Published
Updated
CVE
CVE-2026-46718
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.calcite:calcite-coreintroduced 1.5.0, fixed 1.42.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database