GHSA-c2rv-hwqm-wjpg
Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-46718
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Description
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.calcite:calcite-core | introduced 1.5.0, fixed 1.42.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2026-46718 ADVISORY
- https://github.com/apache/calcite/commit/5855cfa14d8038e2a123ff6ce9722edce0e0cc25 WEB
- https://github.com/apache/calcite PACKAGE
- https://issues.apache.org/jira/browse/CALCITE-7532 WEB
- https://lists.apache.org/thread/9s37svo343w5ck1ovh478lkzcqk4949v WEB
- http://www.openwall.com/lists/oss-security/2026/06/01/7 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |