GHSA-9w3m-gqgf-c4p9

snakeYAML before 1.32 vulnerable to Denial of Service due to Out-of-bounds Write

En bref

Publiée
Mise à jour
CVE
CVE-2022-38752
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DoS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stack-overflow.

Paquets affectés

PaquetVersions
Maven · org.yaml:snakeyamlintroduced 0, fixed 1.32

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database