GHSA-9w3m-gqgf-c4p9
snakeYAML before 1.32 vulnerable to Denial of Service due to Out-of-bounds Write
At a glance
- Published
- Updated
- CVE
- CVE-2022-38752
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Description
Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DoS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stack-overflow.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.yaml:snakeyaml | introduced 0, fixed 1.32 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38752 ADVISORY
- https://bitbucket.org/snakeyaml/snakeyaml PACKAGE
- https://bitbucket.org/snakeyaml/snakeyaml/issues/531/stackoverflow-oss-fuzz-47081 WEB
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47081 WEB
- https://security.gentoo.org/glsa/202305-28 WEB
- https://security.netapp.com/advisory/ntap-20240315-0009 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |