GHSA-9qvm-2vhf-q649

RubyGems Regular Expression Denial of Service

At a glance

Published
Updated
CVE
CVE-2013-4363

Description

Algorithmic complexity vulnerability in `Gem::Version::ANCHORED_VERSION_PATTERN` in `lib/rubygems/version.rb` in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 0, fixed 1.8.23.2
RubyGems · rubygems-updateintroduced 1.8.24, fixed 1.8.27
RubyGems · rubygems-updateintroduced 2.0.0, fixed 2.0.10
RubyGems · rubygems-updateintroduced 2.1.0, fixed 2.1.5

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database