GHSA-9qvm-2vhf-q649
RubyGems Regular Expression Denial of Service
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2013-4363
Description
Algorithmic complexity vulnerability in `Gem::Version::ANCHORED_VERSION_PATTERN` in `lib/rubygems/version.rb` in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.
Paquets affectés
| Paquet | Versions |
|---|---|
| RubyGems · rubygems-update | introduced 0, fixed 1.8.23.2 |
| RubyGems · rubygems-update | introduced 1.8.24, fixed 1.8.27 |
| RubyGems · rubygems-update | introduced 2.0.0, fixed 2.0.10 |
| RubyGems · rubygems-update | introduced 2.1.0, fixed 2.1.5 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2013-4363 ADVISORY
- https://github.com/rubygems/rubygems PACKAGE
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2013-4363.yml WEB
- https://web.archive.org/web/20170331150441/https://puppet.com/security/cve/cve-2013-4363 WEB
- http://blog.rubygems.org/2013/09/24/CVE-2013-4363.html WEB
- http://www.openwall.com/lists/oss-security/2013/09/14/3 WEB
- http://www.openwall.com/lists/oss-security/2013/09/18/8 WEB
- http://www.openwall.com/lists/oss-security/2013/09/20/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |