GHSA-9h63-7qf6-mv6r
Improper Authorization in github.com/containers/libpod
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2021-20188
- Alias
- GO-2022-0641
- CVSS_V3
- CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Paquets affectés
| Paquet | Versions |
|---|---|
| Go · github.com/containers/libpod | introduced 0, fixed 1.7.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2021-20188 ADVISORY
- https://github.com/containers/podman/commit/2c7b579fe7328dc6db48bdaf60d0ddd9136b1e24 WEB
- https://github.com/containers/podman/commit/c8bd4746151e6ae37d49c4688f2f64e03db429fc WEB
- https://github.com/containers/podman/commit/dcf3c742b1ac4d641d66810113f3d17441a412f4 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1915734 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |