GHSA-9h63-7qf6-mv6r

Improper Authorization in github.com/containers/libpod

At a glance

Published
Updated
CVE
CVE-2021-20188
Aliases
GO-2022-0641
CVSS_V3
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Affected packages

PackageVersions
Go · github.com/containers/libpodintroduced 0, fixed 1.7.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database