GHSA-9ggw-87m9-9gfc

Spring Web Flow has Data Binding Vulnerability with Unified EL Parser

En bref

Publiée
Mise à jour
CVE
CVE-2026-40985
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N

Description

Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions. Affected versions: Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.

Paquets affectés

PaquetVersions
Maven · org.springframework.webflow:spring-webflowintroduced 4.0.0, fixed 4.0.1
Maven · org.springframework.webflow:spring-webflowintroduced 3.0.0, fixed 3.0.2
Maven · org.springframework.webflow:spring-webflowintroduced 0, last affected 2.5.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database