GHSA-9ggw-87m9-9gfc
Spring Web Flow has Data Binding Vulnerability with Unified EL Parser
At a glance
- Published
- Updated
- CVE
- CVE-2026-40985
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
Description
Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions. Affected versions: Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.springframework.webflow:spring-webflow | introduced 4.0.0, fixed 4.0.1 |
| Maven · org.springframework.webflow:spring-webflow | introduced 3.0.0, fixed 3.0.2 |
| Maven · org.springframework.webflow:spring-webflow | introduced 0, last affected 2.5.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-40985 ADVISORY
- https://github.com/spring-projects/spring-webflow PACKAGE
- https://spring.io/security/cve-2026-40985 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |