GHSA-89ch-hqf9-rgp3
Using JS libraries with known security vulnerabilities
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-8121
Description
An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Magento 2 codebase leveraged outdated versions of JS libraries (Bootstrap, jquery, Knockout) with known security vulnerabilities.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 2.2, fixed 2.2.10 |
| Packagist · magento/community-edition | introduced 2.3, fixed 2.3.3 |
| Packagist · magento/product-community-edition | introduced 2.2, fixed 2.2.10 |
| Packagist · magento/product-community-edition | introduced 2.3, fixed 2.3.2-p2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2019-8121 ADVISORY
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8121.yaml WEB
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |