GHSA-89ch-hqf9-rgp3

Using JS libraries with known security vulnerabilities

At a glance

Published
Updated
CVE
CVE-2019-8121

Description

An insecure component vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Magento 2 codebase leveraged outdated versions of JS libraries (Bootstrap, jquery, Knockout) with known security vulnerabilities.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.2, fixed 2.2.10
Packagist · magento/community-editionintroduced 2.3, fixed 2.3.3
Packagist · magento/product-community-editionintroduced 2.2, fixed 2.2.10
Packagist · magento/product-community-editionintroduced 2.3, fixed 2.3.2-p2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database