GHSA-85wq-pqhp-hmq6
Cross-Site Request Forgery in Jenkins
At a glance
- Published
- Updated
- CVE
- CVE-2017-1000356
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication realm: create an account if signup is enabled; or create an account if the victim is an administrator, possibly deleting the existing default admin user in the process and allowing a wide variety of impacts.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.50, fixed 2.57 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.46.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000356 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/23f4809e6c10a221e9d67f2e841536845387b42d WEB
- https://github.com/jenkinsci/jenkins/commit/3c5e5ca63d9a1ac1c4087682dc0d426625eafed8 WEB
- https://github.com/jenkinsci/jenkins/commit/e69c28e44dae41322112471e1c80f840bde314d4 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2017-04-26 WEB
- http://www.securityfocus.com/bid/98062 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |