GHSA-85wq-pqhp-hmq6

Cross-Site Request Forgery in Jenkins

En bref

Publiée
Mise à jour
CVE
CVE-2017-1000356
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication realm: create an account if signup is enabled; or create an account if the victim is an administrator, possibly deleting the existing default admin user in the process and allowing a wide variety of impacts.

Paquets affectés

PaquetVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.50, fixed 2.57
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.46.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database