GHSA-7px7-7xjx-hxm8
Marked vulnerable to XSS from data URIs
At a glance
- Published
- Updated
- CVE
- CVE-2017-1000427
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
Affected packages
| Package | Versions |
|---|---|
| npm · marked | introduced 0, fixed 0.3.7 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000427 ADVISORY
- https://github.com/advisories/GHSA-7px7-7xjx-hxm8 ADVISORY
- https://github.com/markedjs/marked PACKAGE
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S WEB
- https://snyk.io/vuln/npm:marked:20170112 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |