GHSA-6wp6-22x5-rr3w
Flowise vulnerable to code injection via api/v1
At a glance
- Published
- Updated
- CVE
- CVE-2024-31621
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N
Description
An issue in FlowiseAI Inc Flowise prior to v1.8.1 allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.
Affected packages
| Package | Versions |
|---|---|
| npm · flowise | introduced 0, fixed 1.8.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-31621 ADVISORY
- https://github.com/FlowiseAI/Flowise/commit/e32b64344544312bf38b3e1fefe7b26c1776a426 WEB
- https://flowiseai.com WEB
- https://github.com/FlowiseAI/Flowise PACKAGE
- https://github.com/FlowiseAI/Flowise/blob/flowise%401.6.5/packages/server/src/index.ts#L143-L147 WEB
- https://www.exploit-db.com/exploits/52001 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |