GHSA-5946-8p38-vffp

Apache Airflow Improper Input Validation vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-22888
Alias
BIT-airflow-2023-22888, PYSEC-2023-105
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to cause a service disruption by manipulating the run_id parameter. This vulnerability is considered low since it requires an authenticated user to exploit it. It is recommended to upgrade to a version that is not affected

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.6.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database