GHSA-5946-8p38-vffp
Apache Airflow Improper Input Validation vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-22888
- Aliases
- BIT-airflow-2023-22888, PYSEC-2023-105
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to cause a service disruption by manipulating the run_id parameter. This vulnerability is considered low since it requires an authenticated user to exploit it. It is recommended to upgrade to a version that is not affected
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.6.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-22888 ADVISORY
- https://github.com/apache/airflow/pull/32293 WEB
- https://github.com/apache/airflow/commit/05bd90f563649f2e9c8f0c85cf5838315a665a02 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-105.yaml WEB
- https://lists.apache.org/thread/dnlht2hvm7k81k5tgjtsfmk27c76kq7z WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |