GHSA-5938-79hg-xh3q
Apache Airflow Improper Access Control vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-50783
- Aliases
- BIT-airflow-2023-50783, PYSEC-2023-267
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Description
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.8.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-50783 ADVISORY
- https://github.com/apache/airflow/pull/33932 WEB
- https://github.com/apache/airflow/commit/0e1c106d7cd0703125528a691088e42e17c99929 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-267.yaml WEB
- https://lists.apache.org/thread/rs7cr3yp726mb89s1m844hy9pq7frgcn WEB
- http://www.openwall.com/lists/oss-security/2023/12/21/4 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |