GHSA-5938-79hg-xh3q

Apache Airflow Improper Access Control vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-50783
Alias
BIT-airflow-2023-50783, PYSEC-2023-267
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Description

Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.8.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database