GHSA-4qxc-qxrp-33cw

Moodle denial-of-service risk in the draft files area

At a glance

Published
Updated
CVE
CVE-2021-32476
Aliases
BIT-moodle-2021-32476
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

Affected packages

PackageVersions
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.4
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.7
Packagist · moodle/moodleintroduced 3.8, fixed 3.8.9
Packagist · moodle/moodleintroduced 3.5.17, fixed 3.5.18

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database