GHSA-4qxc-qxrp-33cw
Moodle denial-of-service risk in the draft files area
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2021-32476
- Alias
- BIT-moodle-2021-32476
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
A denial-of-service risk was identified in the draft files area, due to it not respecting user file upload limits. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · moodle/moodle | introduced 3.10, fixed 3.10.4 |
| Packagist · moodle/moodle | introduced 3.9, fixed 3.9.7 |
| Packagist · moodle/moodle | introduced 3.8, fixed 3.8.9 |
| Packagist · moodle/moodle | introduced 3.5.17, fixed 3.5.18 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2021-32476 ADVISORY
- https://github.com/moodle/moodle PACKAGE
- https://moodle.org/mod/forum/discuss.php?d=422310 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |