GHSA-3h4r-pjv6-cph9
RubyGems Escape sequence injection vulnerability in api response handling
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-8323
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.
Paquets affectés
| Paquet | Versions |
|---|---|
| RubyGems · rubygems-update | introduced 2.6.0, fixed 2.7.9 |
| RubyGems · rubygems-update | introduced 3.0.0, fixed 3.0.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2019-8323 ADVISORY
- https://hackerone.com/reports/315081 WEB
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2019-8323.yml WEB
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |