GHSA-3h4r-pjv6-cph9

RubyGems Escape sequence injection vulnerability in api response handling

At a glance

Published
Updated
CVE
CVE-2019-8323
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 2.6.0, fixed 2.7.9
RubyGems · rubygems-updateintroduced 3.0.0, fixed 3.0.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database