GHSA-3h4m-m55v-gx4m
Apache Airflow Improper Input Validation vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-36543
- Aliases
- BIT-airflow-2023-36543, PYSEC-2023-106
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
Apache Airflow, versions before 2.6.3, has a vulnerability where an authenticated user can use crafted input to make the current request hang. It is recommended to upgrade to a version that is not affected
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.6.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-36543 ADVISORY
- https://github.com/apache/airflow/pull/32060 WEB
- https://github.com/apache/airflow/commit/116e607ddcb32480e57c342f48226545ac6fc315 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-106.yaml WEB
- https://lists.apache.org/thread/tokfs980504ylgk3cv3hjlnrtbv4tng4 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |