GHSA-2qph-q8xw-gv7q
Drupal Core Improperly Controlled Modification of Dynamically-Determined Object Attributes Vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2025-31674
- Aliases
- BIT-drupal-2025-31674, DRUPAL-CORE-2025-003
- CVSS_V4
- CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Description
Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
Affected packages
| Package | Versions |
|---|---|
| Packagist · drupal/core | introduced 8.0.0, fixed 10.3.13 |
| Packagist · drupal/core | introduced 10.4.0, fixed 10.4.3 |
| Packagist · drupal/core | introduced 11.0.0, fixed 11.0.12 |
| Packagist · drupal/core | introduced 11.1.0, fixed 11.1.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-31674 ADVISORY
- https://github.com/drupal/core PACKAGE
- https://www.drupal.org/sa-core-2025-003 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |