GHSA-2h84-3crq-vgfj
Apache Airflow Incorrect Authorization vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-35908
- Aliases
- BIT-airflow-2023-35908, PYSEC-2023-119
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Description
Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows unauthorized read access to a DAG through the URL. It is recommended to upgrade to a version that is not affected
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.6.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-35908 ADVISORY
- https://github.com/apache/airflow/pull/32014 WEB
- https://github.com/apache/airflow/commit/ac65b82eeeeaa670e09a83c7da65cbac7e89f8db WEB
- https://github.com/apache/airflow/commit/c78e16588ee399f6eaf60425eb1ad7fa6d3fe352 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-119.yaml WEB
- https://lists.apache.org/thread/vsflptk5dt30vrfggn96nx87d7zr6yvw WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |