Quagga bgpd

4 published vulnerabilities name this product.

As the CNAs write it in their CVE records (vendor and product); the versions are theirs.

CVEVulnerable versionsTitleSeverityPublishedEPSSExploitation
CVE-2018-5381bpgd – < 1.2.3The Quagga BGP daemon (bgpd) prior to version 1.2.3 has a bug in its parsing of "Capabilities" in BGP OPEN messages, in the bgp_packet.c:bgpHIGH 7.530 %
CVE-2018-5380bpgd – < 1.2.3The Quagga BGP daemon (bgpd) prior to version 1.2.3 can overrun internal BGP code-to-string conversion tables used for debug by 1 pointer vaMEDIUM 4.315 %
CVE-2018-5379bpgd – < 1.2.3The Quagga BGP daemon (bgpd) prior to version 1.2.3 can double-free memory when processing certain forms of UPDATE message, containing clustCRITICAL 9.838 %
CVE-2018-5378bpgd – < 1.2.3The Quagga BGP daemon (bgpd) prior to version 1.2.3 does not properly bounds check the data sent with a NOTIFY to a peer, if an attribute leHIGH 7.174 %