GStreamer

10 vulnérabilités publiées citent ce produit.

Tel que les CNA l’écrivent dans leurs fiches CVE (éditeur et produit) ; les versions sont les leurs.

CVEVersions vulnérablesTitreSévéritéPubliéeEPSSExploitation
CVE-2022-19241.20.3DOS / potential heap overwrite in mkv demuxing using lzo decompression. Integer overflow in matroskademux element in lzo decompression functHIGH 7.80.4 %
CVE-2022-19231.20.3DOS / potential heap overwrite in mkv demuxing using bzip decompression. Integer overflow in matroskademux element in bzip decompression funHIGH 7.80.4 %
CVE-2022-21221.20.3DOS / potential heap overwrite in qtdemux using zlib decompression. Integer overflow in qtdemux element in qtdemux_inflate function which caHIGH 7.80.5 %
CVE-2022-19251.20.3DOS / potential heap overwrite in mkv demuxing using HEADERSTRIP decompression. Integer overflow in matroskaparse element in gst_matroska_deHIGH 7.80.5 %
CVE-2022-19221.20.3DOS / potential heap overwrite in mkv demuxing using zlib decompression. Integer overflow in matroskademux element in gst_matroska_decompresHIGH 7.80.5 %
CVE-2022-19201.20.3Integer overflow in matroskademux element in gst_matroska_demux_add_wvpk_header function which allows a heap overwrite while parsing matroskHIGH 7.80.5 %
CVE-2022-19211.20.3Integer overflow in avidemux element in gst_avi_demux_invert function which allows a heap overwrite while parsing avi files. Potential for aHIGH 7.80.5 %
CVE-2021-3522All GStreamer version before 1.18.4GStreamer before 1.18.4 may perform an out-of-bounds read when handling certain ID3v2 tags.MEDIUM 5.55.4 %
CVE-2021-3185Fixed in gst-plugins-bad-1.18.1A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could causeCRITICAL 9.82.5 %
CVE-2020-6095GStreamer gst-rtsp-server 1.14.5An exploitable denial of service vulnerability exists in the GstRTSPAuth functionality of GStreamer/gst-rtsp-server 1.14.5. A specially crafHIGH 7.52.9 %