CVE-2026-86246
Apache Tomcat Native: Insecure OpenSSL options enabled
CRITICAL 9.1
At a glance
- Source
- NVD
- EPSS
- EPSS 0.35 % · percentile 28 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Analyzed
Description
Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled insecure options by default including ALLOW_CLIENT_RENEGOTIATION, NO_EXTENDED_MASTER_SECRET, IGNORE_UNEXPECTED_EOF and ALLOW_NO_DHE_KEX. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fix the issue.
Weaknesses (CWE)
- CWE-1188 — Initialization of a Resource with an Insecure Default
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | CRITICAL 9.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N | CISA-ADP |
| CVSS 3.1 | CRITICAL 9.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
European references
- ENISA EUVD · EUVD-2026-85268
- GCVE · GCVE-0-2026-86246
Affected configurations (NVD CPE)
cpe:2.3:a:apache:tomcat_native:*:*:*:*:*:*:*:*≥ 1.3.0 < 1.3.9cpe:2.3:a:apache:tomcat_native:*:*:*:*:*:*:*:*≥ 2.0.0 < 2.0.16
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache Tomcat Native | affected 2.0.0 ≤ 2.0.15 ; affected 1.3.0 ≤ 1.3.8 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |