CVE-2026-7210
The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection
MEDIUM 6.3
At a glance
- Source
- NVD
- EPSS
- EPSS 0.67 % · percentile 52 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- PSF
- NVD status
- Modified
Description
`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.
Weaknesses (CWE)
- CWE-331 — Insufficient Entropy
References
- https://mail.python.org/archives/list/security-announce@python.org/thread/PNY5OMBDPM2FRUZTWFFPJ6LISWKV627K/
- https://github.com/python/cpython/pull/149023
- https://github.com/python/cpython/issues/149018
- https://github.com/python/cpython/commit/24b8f12544468e4cedf5bfbe25442fcd495391e4
- https://github.com/python/cpython/commit/3573b3b1ecbd99030a0b18658e1bfece771b2566
- https://github.com/python/cpython/commit/eeea765cb9d8f1fc3d8918b272ac3c477983f27a
- https://github.com/python/cpython/commit/fc9b11ff49cbc82e6f917d07a61517a2b5f3145f
- https://github.com/python/cpython/commit/e37df2a6a71d6538698e2d3188a7c345b827640b
- https://github.com/python/cpython/commit/cbaecf9f16da611a646d507c1cbca265c588fc56
- https://github.com/python/cpython/commit/ea70712d1a8508e14e9677d44f838dab04dc0286
- http://www.openwall.com/lists/oss-security/2026/05/11/8
- http://www.openwall.com/lists/oss-security/2026/05/11/13
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 4.0 | MEDIUM 6.3 | CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | PSF |
| CVSS 4.0 | MEDIUM 6.3 | CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · cna@python.org (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
European references
- ENISA EUVD · EUVD-2026-29178
- GCVE · GCVE-0-2026-7210
CERT-FR advisories
- CERTFR-2026-AVI-1385 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0560 — Vulnérabilité dans CPython · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:python:python:*:*:*:*:*:*:*:*< 3.13.14cpe:2.3:a:python:python:*:*:*:*:*:*:*:*≥ 3.14.0 < 3.14.6cpe:2.3:a:python:python:3.15.0:alpha1:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha2:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha3:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha4:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha5:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha6:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha7:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:alpha8:*:*:*:*:*:*cpe:2.3:a:python:python:3.15.0:beta1:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| Python Software Foundation · CPython | affected 0 < 3.10.22 ; affected 3.11.0 < 3.11.16 ; affected 3.12.0 < 3.12.14 ; affected 3.13.0 < 3.13.14 ; affected 3.14.0 < 3.14.6 ; affected 3.15.0a1 < 3.15.0b2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |