CVE-2026-6637
PostgreSQL refint allows stack buffer overflow and SQL injection
HIGH 8.8
En bref
- Source
- NVD
- EPSS
- EPSS 0.37 % · centile 31 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- PostgreSQL
- Statut NVD
- Analyzed
Description
Stack buffer overflow in PostgreSQL module "refint" allows an unprivileged database user to execute arbitrary code as the operating system user running the database. A distinct attack is possible if the application declares a user-controlled column as a "refint" cascade primary key and facilitates user-controlled updates to that column. In that case, a SQL injection allows a primary key update value provider to execute arbitrary SQL as the database user performing the primary key update. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
Faiblesses (CWE)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | PostgreSQL |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · f86ef6dc-4d3a-42ad-8f28-e6d5547a5007 (Secondary) |
Références européennes
- ENISA EUVD · EUVD-2026-30291
- GCVE · GCVE-0-2026-6637
Avis du CERT-FR
- CERTFR-2026-AVI-1385 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1366 — Multiples vulnérabilités dans les produits Splunk · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1067 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1056 — Multiples vulnérabilités dans les produits Splunk · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0962 — Multiples vulnérabilités dans les produits Tenable · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0905 — Multiples vulnérabilités dans Tenable Security Center · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0816 — Multiples vulnérabilités dans Stormshield Management Center · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0788 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0612 — Multiples vulnérabilités dans les produits Microsoft · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0595 — Multiples vulnérabilités dans PostgreSQL · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*< 14.23cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*≥ 15.0 < 15.18cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*≥ 16.0 < 16.14cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*≥ 17.0 < 17.10cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*≥ 18.0 < 18.4
Produits affectés
| Produit | Versions |
|---|---|
| PostgreSQL | affected 18 < 18.4 ; affected 17 < 17.10 ; affected 16 < 16.14 ; affected 15 < 15.18 ; affected 0 < 14.23 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |