CVE-2026-59084
Apache Tomcat: EncryptInterceptor requirements not clearly documented
CRITICAL 9.1
En bref
- Source
- NVD
- EPSS
- EPSS 0.51 % · centile 43 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- apache
- Statut NVD
- Analyzed
Description
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Faiblesses (CWE)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | CRITICAL 9.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N | CISA-ADP |
| CVSS 3.1 | CRITICAL 9.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Références européennes
- ENISA EUVD · EUVD-2026-43640
- GCVE · GCVE-0-2026-59084
Avis du CERT-FR
- CERTFR-2026-AVI-1385 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1336 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1249 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1206 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1165 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1094 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0876 — Multiples vulnérabilités dans Apache Tomcat · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 7.0.100 ≤ 7.0.109cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 8.5.38 ≤ 8.5.100cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 9.0.13 ≤ 9.0.119cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 10.1.0 ≤ 10.1.56cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 11.0.0 ≤ 11.0.23
Produits affectés
| Produit | Versions |
|---|---|
| Apache Software Foundation · Apache Tomcat | affected 11.0.0-M1 ≤ 11.0.23 ; affected 10.1.0-M1 ≤ 10.1.56 ; affected 9.0.13 ≤ 9.0.119 ; affected 8.5.38 ≤ 8.5.100 ; affected 7.0.100 ≤ 7.0.109 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |