CVE-2026-55955

Apache Tomcat: EncryptInterceptor not protected against replay attacks

MEDIUM 6.5

At a glance

Source
NVD
EPSS
EPSS 0.44 % · percentile 38 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

Weaknesses (CWE)

  • CWE-287 — Improper Authentication

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NCISA-ADP
CVSS 3.1MEDIUM 6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Tomcataffected 11.0.0-M1 ≤ 11.0.22 ; affected 10.1.0-M1 ≤ 10.1.55 ; affected 9.0.13 ≤ 9.0.118 ; affected 8.5.38 ≤ 8.5.100 ; affected 7.0.100 ≤ 7.0.109

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD