CVE-2026-49158

Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

HIGH 7.5

At a glance

Source
NVD
EPSS
EPSS 1.03 % · percentile 64 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weaknesses (CWE)

  • CWE-409 — Improper Handling of Highly Compressed Data (Zip Bomb)

References

Scores

VersionScoreVectorScored by
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hapache
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HNVD · security@apache.org (Secondary)

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Thriftaffected 0 < 0.24.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD