Apache Camel: CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input (Apache Software Foundation Apache Camel)
At a glance
- Source
- NVD
- EPSS
- EPSS 0.69 % · percentile 53 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Analyzed
Description
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Weaknesses (CWE)
- CWE-20 — Improper Input Validation
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L | CISA-ADP |
| CVSS 3.1 | HIGH 7.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Advisories
- GHSA-5g68-f6xg-vf2r — Apache Camel-CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input
European references
- ENISA EUVD · EUVD-2026-41866
- GCVE · GCVE-0-2026-46588
Affected configurations (NVD CPE)
cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*≥ 4.0.0 < 4.14.8cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*≥ 4.15.0 < 4.18.3cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*≥ 4.19.0 < 4.21.0
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache Camel | affected 0 ≤ 4.14.7 ; affected 4.15.0 ≤ 4.18.2 ; affected 4.19.0 ≤ 4.20.0 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |