Apache Commons Configuration: StackOverflowError for YAML input with cycles (Apache Software Foundation Apache Commons Configuration)

CVE-2026-45205
MEDIUM 5.3

En bref

Source
NVD
EPSS
EPSS 0.47 % · centile 41 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
apache
Statut NVD
Analyzed

Description

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

Faiblesses (CWE)

  • CWE-674 — Récursion non maîtrisée

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 5.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LCISA-ADP
CVSS 3.1MEDIUM 5.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Avis

Références européennes

Avis du CERT-FR

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Apache Software Foundation · Apache Commons Configurationaffected 2.2 < 2.15.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD