CVE-2026-45077
Symfony: Unauthenticated PHP Object Deserialization in MonologBridge server:log Listener
HIGH 8.3
At a glance
- Source
- NVD
- EPSS
- EPSS 0.67 % · percentile 52 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Analyzed
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the server:log listener (Symfony\Bridge\Monolog\Command\ServerLogCommand) binds to 0.0.0.0:9911 by default and processes each received frame with unserialize(base64_decode($message)) without authentication, integrity checks, or an allowed_classes allowlist, allowing any reachable host to submit attacker-chosen serialized PHP payloads that can crash the listener and may trigger object-injection gadget effects. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
Weaknesses (CWE)
References
- https://github.com/symfony/symfony/security/advisories/GHSA-m7v2-7gxm-vc2v
- https://github.com/symfony/symfony/commit/0891b2f293896c488e26943dc034334364b77fc4
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 4.0 | HIGH 8.3 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N | GitHub_M |
| CVSS 4.0 | HIGH 8.3 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 8.6 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-m7v2-7gxm-vc2v — Symfony has Unauthenticated PHP Object Deserialization in MonologBridge server:log Listener
European references
- ENISA EUVD · EUVD-2026-44330
- GCVE · GCVE-0-2026-45077
CERT-FR advisories
- CERTFR-2026-AVI-0617 — Multiples vulnérabilités dans Symfony · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*< 5.4.52cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*≥ 6.0.0 < 6.4.40cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*≥ 7.0.0 < 7.4.12cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:*≥ 8.0.0 < 8.0.12
Affected products
| Product | Versions |
|---|---|
| symfony · symfony | affected < 5.4.52 ; affected >= 6.0.0-BETA1, < 6.4.40 ; affected >= 7.0.0-BETA1, < 7.4.12 ; affected >= 8.0.0-BETA1, < 8.0.12 |
| symfony · monolog-bridge | affected < 5.4.52 ; affected >= 6.0.0-BETA1, < 6.4.40 ; affected >= 7.0.0-BETA1, < 7.4.12 ; affected >= 8.0.0-BETA1, < 8.0.12 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |