CVE-2026-44577
Next.js: Denial of Service in the Image Optimization API
MEDIUM 5.9
At a glance
- Source
- NVD
- EPSS
- EPSS 0.74 % · percentile 54 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
Next.js is a React framework for building full-stack web applications. From 10.0.0 to before 15.5.16 and 16.2.5, when self-hosting Next.js with the default image loader, the Image Optimization API fetches local images entirely into memory without enforcing a maximum size limit. An attacker could cause out-of-memory conditions by requesting large local assets from the /_next/image endpoint that match the images.localPatterns configuration (by default, all patterns are allowed). This vulnerability is fixed in 15.5.16 and 16.2.5.
Weaknesses (CWE)
- CWE-770 — Allocation of Resources Without Limits or Throttling
References
- https://github.com/vercel/next.js/security/advisories/GHSA-h64f-5h5j-jqjh
- https://access.redhat.com/security/cve/CVE-2026-44577
- https://bugzilla.redhat.com/show_bug.cgi?id=2477194
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44577.json
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:54435
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub_M |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | redhat-SADP |
| CVSS 3.1 | MEDIUM 5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary) |
Advisories
- GHSA-h64f-5h5j-jqjh — Next.js has a Denial of Service in the Image Optimization API
European references
- ENISA EUVD · EUVD-2026-30061
- GCVE · GCVE-0-2026-44577
CERT-FR advisories
- CERTFR-2026-AVI-1256 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0901 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 10.0.0 < 15.5.16cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 16.0.0 < 16.2.5
Affected products
| Product | Versions |
|---|---|
| vercel · next.js | affected >= 10.0.0, < 15.5.16 ; affected >= 16.0.0, < 16.2.5 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |