CVE-2026-44574
Next.js: Middleware / Proxy bypass through dynamic route parameter injection
HIGH 8.1
At a glance
- Source
- NVD
- EPSS
- EPSS 0.64 % · percentile 50 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
Weaknesses (CWE)
- CWE-288 — Authentication Bypass Using an Alternate Path or Channel
- CWE-551 — Incorrect Behavior Order: Authorization Before Parsing and Canonicalization
References
- https://github.com/vercel/next.js/security/advisories/GHSA-492v-c6pp-mqqv
- https://access.redhat.com/security/cve/CVE-2026-44574
- https://bugzilla.redhat.com/show_bug.cgi?id=2477207
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44574.json
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:54435
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | GitHub_M |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | redhat-SADP |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | NVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary) |
Advisories
- GHSA-492v-c6pp-mqqv — Next.js has a Middleware / Proxy bypass through dynamic route parameter injection
European references
- ENISA EUVD · EUVD-2026-30058
- GCVE · GCVE-0-2026-44574
CERT-FR advisories
- CERTFR-2026-AVI-0901 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 15.4.0 < 15.5.16cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 16.0.0 < 16.2.5
Affected products
| Product | Versions |
|---|---|
| vercel · next.js | affected >= 15.4.0, < 15.5.16 ; affected >= 16.0.0, < 16.2.5 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |