CVE-2026-44573
Next.js: Middleware / Proxy bypass in Pages Router applications using i18n
HIGH 7.5
At a glance
- Source
- NVD
- EPSS
- EPSS 0.80 % · percentile 56 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
Next.js is a React framework for building full-stack web applications. From 12.2.0 to before 15.5.16 and 16.2.5, Applications using the Pages Router with i18n configured and middleware/proxy-based authorization can allow unauthorized access to protected page data through locale-less /_next/data/<buildId>/<page>.json requests. In affected configurations, middleware does not run for the unprefixed data route, allowing an attacker to retrieve SSR JSON for protected pages without passing the intended authorization checks. This vulnerability is fixed in 15.5.16 and 16.2.5.
Weaknesses (CWE)
- CWE-863 — Incorrect Authorization
- CWE-551 — Incorrect Behavior Order: Authorization Before Parsing and Canonicalization
References
- https://github.com/vercel/next.js/security/advisories/GHSA-36qx-fr4f-26g5
- https://access.redhat.com/security/cve/CVE-2026-44573
- https://bugzilla.redhat.com/show_bug.cgi?id=2477199
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44573.json
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:54435
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | GitHub_M |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | redhat-SADP |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary) |
Advisories
- GHSA-36qx-fr4f-26g5 — Next.js has a Middleware / Proxy bypass in Pages Router applications using i18n
European references
- ENISA EUVD · EUVD-2026-30057
- GCVE · GCVE-0-2026-44573
CERT-FR advisories
- CERTFR-2026-AVI-1256 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0901 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 12.2.0 < 15.5.16cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 16.0.0 < 16.2.5
Affected products
| Product | Versions |
|---|---|
| vercel · next.js | affected >= 12.2.0, < 15.5.16 ; affected >= 16.0.0, < 16.2.5 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |