CVE-2026-42271
LiteLLM: Authenticated command execution via MCP stdio test endpoints
En bref
- Source
- NVD
- EPSS
- EPSS 91.44 % · centile 100 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Analyzed
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
Faiblesses (CWE)
Références
- https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271
- https://access.redhat.com/security/cve/CVE-2026-42271
- https://bugzilla.redhat.com/show_bug.cgi?id=2467924
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json
- https://access.redhat.com/errata/RHSA-2026:28960
- https://access.redhat.com/errata/RHSA-2026:30056
- https://access.redhat.com/errata/RHSA-2026:27784
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 4.0 | HIGH 8.7 | CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N | GitHub_M |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | redhat-SADP |
| CVSS 4.0 | HIGH 8.7 | CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary) |
Avis
- GHSA-v4p8-mg3p-g94g — LiteLLM: Authenticated command execution via MCP stdio test endpoints
- PYSEC-2026-2599 — LiteLLM: Authenticated command execution via MCP stdio test endpoints
Références européennes
- ENISA EUVD · EUVD-2026-28507
- GCVE · GCVE-0-2026-42271
Configurations affectées (CPE NVD)
cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:*≥ 1.74.2 < 1.83.7cpe:2.3:a:redhat:openshift_ai:*:*:*:*:*:*:*:*≥ 2.25 < 2.25.8cpe:2.3:a:redhat:openshift_ai:*:*:*:*:*:*:*:*≥ 3.3 < 3.3.4cpe:2.3:a:redhat:openshift_ai:3.4:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| BerriAI · litellm | affected >= 1.74.2, < 1.83.7 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| CISA Known Exploited Vulnerabilities | CC0 1.0 |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |