CVE-2026-33997
Moby: Off-by-one error in plugin privilege validation
MEDIUM 6.8
At a glance
- Source
- NVD
- EPSS
- EPSS 0.40 % · percentile 34 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.
Weaknesses (CWE)
References
- https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9
- https://github.com/moby/moby/releases/tag/docker-v29.3.1
- https://access.redhat.com/security/cve/CVE-2026-33997
- https://bugzilla.redhat.com/show_bug.cgi?id=2453277
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33997.json
- https://access.redhat.com/errata/RHSA-2026:22347
- https://access.redhat.com/errata/RHSA-2026:23345
- https://access.redhat.com/errata/RHSA-2026:21769
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 6.8 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N | GitHub_M |
| CVSS 3.1 | HIGH 8.4 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H | redhat-SADP |
| CVSS 3.1 | MEDIUM 6.8 | CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 3.1 | HIGH 8.4 | CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H | NVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary) |
Advisories
- GHSA-pxq6-2prw-chj9 — Moby has an Off-by-one error in its plugin privilege validation
- GO-2026-4883 — Moby has an Off-by-one error in its plugin privilege validation in github.com/docker/docker
European references
- ENISA EUVD · EUVD-2026-17290
- GCVE · GCVE-0-2026-33997
CERT-FR advisories
- CERTFR-2026-AVI-1336 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:docker:engine:*:*:*:*:*:*:*:*< 29.3.1
Affected products
| Product | Versions |
|---|---|
| moby · moby | affected < 29.3.1 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |