CVE-2026-29146

Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

HIGH 7.5

At a glance

Source
NVD
EPSS
EPSS 8.85 % · percentile 95 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Modified

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Weaknesses (CWE)

  • CWE-209 — Generation of Error Message Containing Sensitive Information
  • CWE-642 — External Control of Critical State Data
  • CWE-1240 — Use of a Cryptographic Primitive with a Risky Implementation

References

Scores

VersionScoreVectorScored by
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NCISA-ADP
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:Nredhat-SADP
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NNVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary)

Advisories

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Tomcataffected 11.0.0-M1 ≤ 11.0.18 ; affected 10.0.0-M1 ≤ 10.1.52 ; affected 9.0.13 ≤ 9.0.115 ; affected 8.5.38 ≤ 8.5.100 ; affected 7.0.100 ≤ 7.0.109

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD