undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (undici undici)
En bref
- Source
- NVD
- EPSS
- EPSS 0.39 % · centile 34 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- openjs
- Statut NVD
- Analyzed
Rechercher sur…
Description
undici's WebSocket client crashes the whole Node.js process during the opening handshake when a server responds with a subprotocol that the client never requested. A default WebSocket connection sends no subprotocol, but if the server's 101 response includes a Sec-WebSocket-Protocol header, undici dereferences a null value while checking it against the requested list and throws an uncaught TypeError. Because that code runs inside a microtask with no surrounding error handling, the exception propagates and terminates the process under Node's default behavior, instead of gracefully failing the connection as required by the WebSocket protocol. Any application that opens a WebSocket to an attacker-controlled or compromised server, or over a plaintext connection subject to a machine-in-the-middle, can be crashed remotely without authentication in the default configuration. This affects undici versions from 6.7.0 up to 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Faiblesses (CWE)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | openjs |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · ce714d77-add3-4f53-aff5-83d477b104bb (Secondary) |
Avis
- GHSA-rfgv-xxqx-mfg5 — undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
Références européennes
- ENISA EUVD · EUVD-2026-71636
- GCVE · GCVE-0-2026-19534
Avis du CERT-FR
- CERTFR-2026-AVI-1378 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1336 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1233 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*≥ 6.7.0 < 6.28.1cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*≥ 7.0.0 < 7.29.1cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*≥ 8.0.0 < 8.10.2
Produits affectés
| Produit | Versions |
|---|---|
| undici · undici | affected 6.7.0 < 6.28.1 ; unaffected 6.28.1 ; affected 7.0.0 < 7.29.1 ; unaffected 7.29.1 ; affected 8.0.0 < 8.10.2 ; unaffected 8.10.2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |