fast-uri vulnerable to host confusion via backslash authority introducer (fast-uri fast-uri)
At a glance
- Source
- NVD
- EPSS
- EPSS 0.38 % · percentile 32 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- openjs
- NVD status
- Analyzed
Description
fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.
Weaknesses (CWE)
- CWE-436 — Interpretation Conflict
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | openjs |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | NVD · ce714d77-add3-4f53-aff5-83d477b104bb (Secondary) |
Advisories
- GHSA-7p8r-x3mc-p8w7 — fast-uri vulnerable to host confusion via backslash authority introducer
European references
- ENISA EUVD · EUVD-2026-51553
- GCVE · GCVE-0-2026-18446
CERT-FR advisories
- CERTFR-2026-AVI-1336 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1291 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1256 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1233 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1165 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1094 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:openjsf:fast-uri:*:*:*:*:*:node.js:*:*< 2.4.4cpe:2.3:a:openjsf:fast-uri:*:*:*:*:*:node.js:*:*≥ 3.0.0 < 3.1.5cpe:2.3:a:openjsf:fast-uri:*:*:*:*:*:node.js:*:*≥ 4.0.0 < 4.1.2
Affected products
| Product | Versions |
|---|---|
| fast-uri · fast-uri | affected 4.0.0 < 4.1.2 ; unaffected 4.1.2 ; affected 3.0.0 < 3.1.5 ; unaffected 3.1.5 ; affected 0 < 2.4.4 ; unaffected 2.4.4 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |