fast-uri vulnerable to host confusion via literal backslash authority delimiter (fast-uri fast-uri)
En bref
- Source
- NVD
- EPSS
- EPSS 0.44 % · centile 38 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- openjs
- Statut NVD
- Analyzed
Rechercher sur…
Description
Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3. Workarounds: none.
Faiblesses (CWE)
- CWE-436 — Conflit d'interprétation
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | openjs |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | NVD · ce714d77-add3-4f53-aff5-83d477b104bb (Secondary) |
Avis
- GHSA-v2hh-gcrm-f6hx — fast-uri vulnerable to host confusion via literal backslash authority delimiter
Références européennes
- ENISA EUVD · EUVD-2026-45551
- GCVE · GCVE-0-2026-16221
Avis du CERT-FR
- CERTFR-2026-AVI-1336 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1291 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1256 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1233 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1165 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1094 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:openjsf:fast-uri:*:*:*:*:*:node.js:*:*≥ 2.3.1 < 2.4.3cpe:2.3:a:openjsf:fast-uri:*:*:*:*:*:node.js:*:*≥ 3.0.0 < 3.1.4cpe:2.3:a:openjsf:fast-uri:*:*:*:*:*:node.js:*:*≥ 4.0.0 < 4.1.1
Produits affectés
| Produit | Versions |
|---|---|
| fast-uri · fast-uri | affected 2.3.1 < 2.4.3 ; unaffected 2.4.3 ; affected 3.0.0 < 3.1.4 ; unaffected 3.1.4 ; affected 4.0.0 < 4.1.1 ; unaffected 4.1.1 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |