CVE-2025-61915

OpenPrinting CUPS vulnerable to stack based out-of-bound write

MEDIUM 6.0

At a glance

Source
NVD
EPSS
EPSS 0.46 % · percentile 40 ()
State
PUBLISHED
Published
Updated
Assigner
GitHub_M
NVD status
Analyzed

Description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

Weaknesses (CWE)

  • CWE-129 — Improper Validation of Array Index
  • CWE-124 — Buffer Underwrite

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 6.0CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:HGitHub_M
CVSS 3.1MEDIUM 6.0CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:HNVD · security-advisories@github.com (Secondary)
CVSS 3.1MEDIUM 6.7CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HNVD · nvd@nist.gov (Primary)

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
OpenPrinting · cupsaffected < 2.4.15

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD