vercel next
At a glance
- Source
- NVD
- EPSS
- EPSS 0.43 % · percentile 37 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- hackerone
- NVD status
- Analyzed
Description
A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode. The PPR resume endpoint accepts unauthenticated POST requests with the `Next-Resume: 1` header and processes attacker-controlled postponed state data. Two closely related vulnerabilities allow an attacker to crash the server process through memory exhaustion: 1. **Unbounded request body buffering**: The server buffers the entire POST request body into memory using `Buffer.concat()` without enforcing any size limit, allowing arbitrarily large payloads to exhaust available memory. 2. **Unbounded decompression (zipbomb)**: The resume data cache is decompressed using `inflateSync()` without limiting the decompressed output size. A small compressed payload can expand to hundreds of megabytes or gigabytes, causing memory exhaustion. Both attack vectors result in a fatal V8 out-of-memory error (`FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory`) causing the Node.js process to terminate. The zipbomb variant is particularly dangerous as it can bypass reverse proxy request size limits while still causing large memory allocation on the server. To be affected you must have an application running with `experimental.ppr: true` or `cacheComponents: true` configured along with the NEXT_PRIVATE_MINIMAL_MODE=1 environment variable. Strongly consider upgrading to 15.6.0-canary.61 or 16.1.5 to reduce risk and prevent availability issues in Next applications.
Weaknesses (CWE)
- CWE-400 — Uncontrolled Resource Consumption
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H | hackerone |
| CVSS 3.1 | MEDIUM 5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · support@hackerone.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-5f7q-jpqc-wp7h — Next.js has Unbounded Memory Consumption via PPR Resume Endpoint
European references
- ENISA EUVD · EUVD-2025-206333
- GCVE · GCVE-0-2025-59472
CERT-FR advisories
- CERTFR-2026-AVI-0901 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0667 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 15.0.0 < 15.6.0cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 16.0.0 < 16.1.5cpe:2.3:a:vercel:next.js:15.6.0:-:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary0:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary1:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary10:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary11:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary12:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary13:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary14:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary15:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary16:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary17:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary18:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary19:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary2:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary20:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary21:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary22:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary23:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary24:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary25:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary26:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary27:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary28:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary29:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary3:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary30:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary31:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary32:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary33:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary34:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary35:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary36:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary37:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary38:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary39:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary4:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary40:*:*:*:node.js:*:*cpe:2.3:a:vercel:next.js:15.6.0:canary41:*:*:*:node.js:*:*- +24 more
Affected products
| Product | Versions |
|---|---|
| vercel · next | affected 15.0.0-canary.0 < 15.0.0 ; affected 15.0.1-canary.0 < 15.0.1 ; affected 15.0.2-canary.0 < 15.0.2 ; affected 15.0.3-canary.0 < 15.0.3 ; affected 15.0.4-canary.0 < 15.0.4 ; affected 15.1.0-canary.0 < 15.1.0 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |