Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons (Apache Software Foundation Apache Jackrabbit)

CVE-2025-53689
HIGH 8.8

At a glance

Source
NVD
EPSS
EPSS 0.54 % · percentile 45 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Modified

Description

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Weaknesses (CWE)

  • CWE-611 — Improper Restriction of XML External Entity Reference

References

Scores

VersionScoreVectorScored by
CVSS 3.1HIGH 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HCISA-ADP
CVSS 3.1HIGH 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Advisories

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Jackrabbitaffected 2.20.0 < 2.20.17 ; affected 2.22.0 < 2.22.1 ; affected 2.23.0-beta < 2.23.2-beta

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD